English (United Kingdom)
Knowledge Base  >  Vik Rent Car  >  JavaScript Conflicts after updating to WordPress 5.5

Some Vik Rent Car functions stop working after updating to WP 5.5. What to do?

WordPress 5.5 was released as a major update on August 11th 2020. This is considered as an "epic release" because it definitely brings some useful new features such as automatic updates for plugins and themes, XML sitemaps, lazy-loading for images etc..

However, this "epic" update is also dropping the support for some jQuery libraries, and this may cause several JavaScript errors on the various websites by breaking some functions, including in our Vik plugins.

For example, datepicker calendars may stop working, drop down menus may look broken, and the JavaScript console of your browser will most likely contain a lot of errors.

What caused these issues?

Just like how "The WordPress Team" states, with the update to WordPress 5.5, a migration tool known as jquery-migrate will no longer be enabled by default. This may lead to unexpected behaviors in some themes or plugins who run older code.

So this is the reason of all the unexpected behaviors you may find in your website after upgrading to WordPress 5.5.

Why was this support removed?

JavaScript plugins like jQuery normally deprecate some of their functions as soon as they evolve, and so dropping the support for this jQuery helper plugin was something that had to be expected to happen sooner or later. However, the problem is that many other jQuery libraries included by default in the WordPress core framework will suffer from this change, by kind of breaking the layout/functioning of your website. For example, jQuery UI and all its related sub-libraries, will start generating JavaScript errors.

In fact, not only our Vik plugins will generate errors on your website, it is known that also those who use WooCommerce will face breaking changes and unexpected behaviors. Maybe your Theme or other plugins will be affected by these changes as well, it all depends on what jQuery libraries they rely on.

We are now in a transitional phase where certain jQuery functions should be modified, but WordPress itself still contains outdated libraries (jQuery UI) that do not support this breaking change (Draggable, Sortable, Datepicker etc..). Therefore, no plugins or Themes should really be blamed for these errors, because WordPress itself still comes with outdated libraries that will generate internal conflicts.

What's the solution?

Luckily, there's a very simple solution to all these problems. All you need to do is to install and activate an official plugin developed by the WordPress Team that will fix all the incomatibility issues between the various jQuery libraries.

This plugin is called "Enable jQuery Migrate Helper" and it has got more than 100.000 active installations after just one week from the release date of WordPress 5.5.
This is a simple plugin that will load an extra and light-weight JavaScript file (the jQuery Migrate plugin) on all pages of your website to fix any kind of conflicts or errors.

From the Plugins section of your WordPress website (wp-admin), click "Add New" and then look for the plugin "Enable jQuery Migrate Helper". Click on install and then on activate to solve all problems.

Is it recommended to upgrade to WordPress 5.5?

Absolutely yes. Using the latest version of the core framework is always a good choice. However, this time upgrading to a newer release may also require to install an additional plugin. You have probably been used for months/years to upgrading your WordPress website without even thinking of the consequences this may cause, and this time there was indeed an important consequence. In any case, there is always a solution to such problems, so make sure to always keep your WordPress installation up to date just like our Vik plugins.

Plugin Homepage:

https://wordpress.org/plugins/enable-jquery-migrate-helper/

Last Update: 2020-08-28
Helpful?
This site uses cookies. By continuing to browse you accept their use. Further information